Degraded Performance in Downstream Services

Incident Report for SoSafe

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 16:24 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2025 - 16:17 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 08, 2025 - 16:02 CEST

Update

We are continuing to investigate this issue.
Posted Jul 08, 2025 - 13:56 CEST

Investigating

Due to performance degradation in downstream systems, users may experience slower than normal response times. We are actively working to resolve this issue
Posted Jul 08, 2025 - 13:54 CEST
This incident affected: SoSafe Manager, SoSafe E-Learning Platform & SCORM Streaming, SoSafe API, SoSafe Phishing Report Button, and SoSafe Login & Identity Management.