We are pleased to inform you that the incident has been resolved. The issue was caused by a temporary false classification of our Email domain in Microsoft's Global Email Infrastructure. The issue has now been fully mitigated and no emails have been lost.
Posted Nov 06, 2024 - 11:24 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 06, 2024 - 09:49 CET
Update
Our team of engineers is still working on the incident. The issue is currently affecting all of SoSafe E-Learning Platform related E-Mails, this includes but is not limited to: - modules & demo emails - reminder emails - password reset emails
Posted Nov 05, 2024 - 16:39 CET
Identified
Our email servers are currently experiencing an issue with a 3rd party provider preventing partially the delivering of mails.